Oplossing: Nexus Mod Manager kon geen versie-informatie ophalen van de updateserver

Fix Nexus Mod Manager Could Not Get Version Information From Update Server

Nexus Mod Manager is een open source-programma dat is gekoppeld aan Nexus Mods. Het programma is beschikbaar voor Windows en stelt de gebruikers in staat om automatisch mods te downloaden en in hun games te implementeren. Er zijn echter vrij recentelijk veel rapporten binnengekomen van gebruikers die geen updates voor de applicatie konden ophalen. De applicatie geeft de foutmelding 'Nexus Mod Manager Updater: kon versie-informatie niet ophalen van de updateserver”Tijdens het updaten.

Het foutbericht Updates mislukt.



Wat veroorzaakt de update-fout van de Nexus Mod Manager?

Na ons onderzoek van de kwestie hebben we een reeks oplossingen bedacht die de fout voor de meeste van onze gebruikers hebben opgelost. We hebben ook de oorzaken van het probleem onderzocht en enkele van de meest voorkomende worden hieronder vermeld.



  • Administratieve privileges: In sommige gevallen kan deze fout optreden doordat de applicatie onvoldoende rechten heeft. Wanneer de Launcher probeert contact te maken met de servers en op de harde schijf schrijft, verhindert dit onvoldoende rechten.
  • Firewall: Soms kan de Windows-firewall ervoor zorgen dat bepaalde elementen van de applicatie geen contact maken met de servers. Dit kan ervoor zorgen dat de client niet updatet, wat in deze fout resulteert.
  • Protocolfout: In de vorige versies van de applicatie werd het HTTP-protocol gebruikt. In de nieuwere versies wordt echter het HTTPs-protocol gebruikt. Het HTTPs-protocol is nodig vanwege de recente wetten die in Europa zijn aangenomen, waardoor alle websites het HTTPs-protocol moeten gebruiken. Nexus Mods zijn ook bijgewerkt naar het HTTPs-protocol. Daarom kunnen de oudere versies van de applicatie geen verbinding meer maken.
  • Verouderde applicatie: In sommige gevallen werd deze fout ook gemeld in de nieuwere versies van de applicatie. Daarom is er een nieuwe versie van de applicatie uitgebracht om deze bug op te lossen, maar de Nexus Mods-website heeft hun database niet bijgewerkt naar de nieuwere versie van de applicatie. De update is echter beschikbaar op de Git Hub-site.

Nu u een basiskennis heeft van de aard van het probleem, gaan we verder met de oplossingen. Het is belangrijk dat u deze oplossingen implementeert in de specifieke volgorde waarin ze worden geleverd.



Oplossing 1: beheerdersrechten toekennen.

In sommige gevallen kan deze fout optreden doordat de applicatie onvoldoende rechten heeft. Wanneer de Launcher probeert contact te maken met de servers en op de harde schijf schrijft, verhindert dit onvoldoende rechten. Daarom gaan we in deze stap de applicatie beheerdersrechten geven. Daarom:

  1. Klik met de rechtermuisknop op de toepassingen uitvoerbaar.
  2. Selecteer ' Eigendommen '.
  3. Klik op de ' Compatibiliteit 'Tabblad en vink de' Als administrator uitvoeren ”Doos.
  4. Probeer rennen de applicatie en controleren om te zien of het probleem aanhoudt.

    Beheerdersmachtigingen verlenen.

Oplossing 2: toegang verlenen in firewall.

Soms kan de Windows-firewall ervoor zorgen dat bepaalde elementen van de applicatie geen contact maken met de servers. Dit kan ervoor zorgen dat de client niet updatet, wat in deze fout resulteert. Daarom gaan we in deze stap de toepassing een uitsluiting verlenen in de Windows Firewall. Daarom:



  1. Klik op de Begin Menu en selecteer de “ Instellingen ' icoon.
  2. Klik binnen de instellingen op de ' Updates en beveiliging ' optie.
  3. Selecteer de ' Windows-beveiliging ”Optie in het linkerdeelvenster.
  4. Klik op de ' Firewall- en netwerkbeveiliging ' optie.
  5. Selecteer de ' Sta een applicatie toe via firewall ' optie.
  6. Klik op ' Instellingen veranderen ' naar verlenen de noodzakelijk rechten .
  7. Toestaan ​​' Nexus Mod Manager ”En alle NMM gerelateerde applicaties via zowel “ Openbaar 'En' Privaat ”Netwerken.
  8. Klik op ' OK ', rennen de applicatie en controleren om te zien of het probleem aanhoudt.

    Een applicatie toestaan ​​via de firewall.

Oplossing 3: de applicatie bijwerken.

Er was een bug met de oudere versie van de applicatie waardoor de fout werd geactiveerd. Ook gebruikten de oudere versies van de applicatie het HTTP-protocol in plaats van het HTTPs-protocol. Sinds de Nexus Mods hun servers hebben geüpgraded om het 'HTTPs' -protocol te gebruiken, zijn de oudere versies onbruikbaar geworden. Daarom gaan we in deze stap beide problemen oplossen door de applicatie bij te werken naar de nieuwste versie.

  1. Verwijderen de Nexus Tegen Manager .
  2. Klik hier naar downloaden de laatste versie van de toepassing .
  3. Een keer gedownload , installeren de applicatie.

    De applicatie installeren.

  4. Probeer rennen de Nexus Mod Manager en controleren om te zien of het probleem aanhoudt.
2 minuten gelezen